Use PHP5 to Solve the WordPress Automatic Upgrade Failure for 1and1

I’ve been having issue with WordPress automatic upgrade for quite awhile. It never make any progress after download completes. This upgrade issue applies to both WordPress itself and its plug-ins. But at that time I’ve never bothered trying to find a solution for it. My WordPress version 2.6 was so far behind. 🙁

After searching on internet, the issue seems to relate to the PHP version. The service provider I using, 1and1, provides both PHP4 and PHP5. And WordPress seems to be confused when both are present. With a quick modification in the .htaccess file as shown below to make it use PHP5, the automatic upgrade for both WordPress and plug-ins are working again. Now I’m on the latest version. 🙂

AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

Reference: http://paheli.net/blog/2009/07/22/solved-wordpress-automatic-upgrade-problem/

, , , , , ,

One Response to Use PHP5 to Solve the WordPress Automatic Upgrade Failure for 1and1

  1. Kristen Robinson March 29, 2011 at 6:56 pm #

    Thanks so much for posting this! I was getting really frustrated b/c my plug-ins were affected and I couldn’t even preview my posts!
    I found this post through Google. Thank you, thank you, thank you!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Powered by WordPress. Designed by WooThemes